Android P не будет поддерживать старые приложения
5

Приложения, изначально разработанные с использованием API Android 4.1 и более старых версий, не будут поддерживаться на устройствах под управлением Android P. Об этом сообщают участники программы предварительного тестирования, получившие доступ к дебютной сборке Developer Preview.

При попытке установить на устройство приложение, несовместимое с новой ОС, на экране появится уведомление с соответствующим содержанием: «Это приложение было создано для более ранней версии Android и может работать некорректно. Проверьте наличие обновлений или обратитесь к разработчику».

На данный момент минимальная версия API, поддерживаемая Android P, имеет номер v17. Он соответствует Android 4.2 Jelly Bean. Если предупреждение о несовместимости не исчезнет в будущих сборках, это может означать, что Google решила провести ревизию в Google Play, освободив каталог от устаревших приложений.

Основная причина наметившейся зачистки магазина приложений заключается в желании Google заставить создателей ПО обновить его в соответствии с новыми требованиями к энергоэффективности. Например, добавить поддержку режима экономии энергии Doze, снижающего расход энергии.

Обсудить ограничение Android P можно в нашем официальном телеграм-чате.

Теги

5 комментариев Оставить свой

  1. Viktor110270 #

    ПРАВИЛЬНО

  2. rahimbekzoda97 #

    Гугл охренели просто, пилят из свободной ос клон iOS и appstore

  3. rahimbekzoda97 #

    Гугл охренели просто пилят из свободной ос клон iOS и Appstore

  4. [email protected] #

    Это кстати началось ещё в Android 8.0 Oreo. Разница в том что в Oreo он не запрещает запускать, а просто предупреждает о возможной некоректной работе.

  5. metall13 #

    3,2 % пользователей сидят на android ниже 4.2.Не так уж и много

Новый комментарий